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Chapter 1

Document History

Revision Number Date Description
0.1 October 2014 Created Document
0.2 January 2015 Created Document
3.2 March 2015 Created Document
3.3 October 2015 Added Silverlight requirement

3.3.7 July 2016 Revised steps and added Windows 2012 installation

Table 1.1: Document History
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Chapter 2

Getting Started

2.1 About this Guide

This guide is written to provide an example procedure for installing and configuring the Sustainment Man-
agement SystemTM (SMS). The procedure described here is for a full installation.

See the corresponding Sustainment Management SystemTM System Administration Guide for information
about

• The procedure to install updates;

• Customizing your installation; or

• Managing this product.

2.2 Using this Guide

IMPORTANT The installation instructions refer to variables in angle brackets (for example,
<VAR APP POOL>) that are used to record and reference installation parameters. Where
these variables appear in the instructions, the corresponding value from the System Configuration
Worksheet (Appendix A) should be substituted. The System Configuration Worksheet worksheet
should be completed prior to or during installation of this product.
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Chapter 3

System Requirements

3.1 Enterprise Configuration

3.1.1 SQL Server

• Windows Server 2008 R2 or later

• SQL Server 2008 Express or SQL Server 2008 R2 or later

• 400 MB free storage per million square feet of managed inventory

• 2.0 GHz or faster processor, 64-bit, 4+ cores

• 8 GB RAM

3.1.2 Application Server

• Windows Server 2008 R2 or later

• Internet Information Services 7.5 or later

• PowerShell 3.0 or later

• 4 GB of free storage plus desired image storage

• 2.0 GHz or faster processor, 64-bit, 4+ cores

• 8 GB RAM with an additional 50 MB per concurrent user

3.2 Single Server Configuration

• Windows Server 2008 R2 or later

• SQL Server 2008 Express or SQL Server 2008 R2 or later

• Internet Information Services 7.5 or later

• PowerShell 3.0 or later

• 4 GB of free storage plus desired image storage and 400 MB free storage per million square feet of
managed inventory

• 2.0 GHz or faster processor, 64-bit, 4+ cores

• 8 GB RAM with an additional 50 MB per concurrent user
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Chapter 4

Client Requirements

4.1 Supported Web Browser

Internet Explorer versions 9 and above are supported; version 10 or above is recommended. In the browser,
you must add an exception to allow popups for the SMS application. It also recommended to add the URL
of the SMS application to your list of trusted sites.

4.2 Microsoft Silverlight

Microsoft Silverlight 5 is a client-side system requirement for running BUILDER’s Functionality and Scenario
Visualization features.
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Chapter 5

Installation

5.1 Summary

The instructions in this chapter are tailored to installation in the enterprise configuration. Differences for a
single-server configuration will be noted.

The enterprise configuration assumes that the application server and the SQL Server are on separate ma-
chines. This supports a greater number of users by distributing the load across multiple servers.

5.2 Server Requirements

5.2.1 Windows Server

If not already created, build a Windows Server 2008 R2 or later machine.

5.2.2 SQL Server

Install SQL Server 2008 Express or SQL Server 2008 R2 or later. Install SQL Server Reporting Services on
the same server, the application server, or a different server as needed for load distribution.

In SQL Server 2014, select (1) Database Engine Services and (2) Management Tools. (See Figure 5.1).

5.2.3 Application Server (Single Server Configuration)

Configure the Windows Server or workstation with an IIS application server role.

Note for Windows 2012: Configure Web Server (IIS) role

A recommended step at this point is to install the .NET Framework prior to installing the SMS. Although
recommended, this step is optional becaue the SMS installer includes the .NET Framework.

5.2.4 Application Server (Enterprise Configuration)

Build another Windows Server 2008 R2 or later machine and configure it with an IIS application server role.

Note for Windows 2012: Configure Web Server (IIS) role

A recommended step at this point is to install the .NET Framework prior to installing the SMS. Although
recommended, this step is optional because the SMS installer includes the .NET Framework.

15
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Figure 5.1: SQL Server 2014 Setup

5.3 Perform Installation Prerequisites

5.3.1 Check PowerShell Version

1. Open the SMS PowerShell.

2. Type $PSVersionTable.PSVersion at the prompt.

3. If the version is less than 3, download and install Windows Management Framework 4.0

Note: Choose Windows6.1-KB2819745-x64-MultiPkg.msu

5.3.2 Create User Account

Depending on the type of SQL Server authentication, create either a domain account or a local account for
the application pool <POOL IDENTITY>:

1. For Trusted Authentication, a domain account is recommended.

2. When using SQL Server Authentication, a local account may be used. This ensures least privilege.

5.3.3 Add Required Features and Roles: Windows 2012

1. Open the Server Manager Snap-in.

2. Select Dashboard in the left pane.

3. Click on Manage in the top right corner.
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4. From the dropdown list, select Add roles and features.

5. Click Next.

6. Make sure that the radio button ”Role-based or feature-based installation” is selected.

7. Click Next.

8. Select a server or virtual hard disk.

9. Click Next. The left column should now be at ”Select Server Roles” (See Figure 5.2).

Figure 5.2: Windows Server 2012 Role Services

10. Optional: Select .NET Extensibility 4.5.

11. Click Next to accept the defaults. The left column should now be at ”Select Features”.

12. Select .NET Framework 4.5 Features\ASP.NET 4.5 or higher.

13. If using SQL 2014, select .NET Framework 3.5 also if this was specified during SQL installation.

14. Select WCF Services\HTTP Activation.

15. Confirm in the dialog box.

16. Click Next.

17. Click Next.

18. Click Next.

19. Click Install.

20. After the installation has completed, click the Close button.
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5.3.4 Add Required Features and Roles: Windows Server 2008 R2

1. Open the Server Manager Snap-in.

2. Select Features in the left pane.

3. Click the Add Features link in the right pane.

4. Select .NET Framework 3.5.1 Features.

5. A dialog box may open; if so, click the Add Required Role Services checkbox.

6. Click Next.

7. Click Next.

8. Select Application Development\ASP.NET (See Figure 5.3).

Figure 5.3: Windows Server 2008 R2 Role Services

9. A dialog box may open; if so, click the Add Required Role Services checkbox.

10. Select Common HTTP Features\Static Content.

11. Select Management Tools\IIS Management Console.

12. Click Next.

13. Click Install.

14. After the installation has completed, click the Close button.
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5.3.5 Install Microsoft Access Database Engine 2010 Redistributable

Download the Microsoft Access Database Engine 2010 Redistributable from http://www.microsoft.com/en-
us/download/details.aspx?id=13255 and install it on the IIS server.

5.3.6 Install SQL Server Feature Pack

From the Microsoft SQL Server 2012 SP2 Feature Pack, download ENV\x64\sqlcli.msi and install it on the
IIS server.

5.4 Install SMS Files

1. Open sustainment-management-system-<VERSION NUMBER>-x86 64-(<LICENSEE>).exe

Figure 5.4: SMS Installer Welcome

2. If prompted by Windows Security, click Run.

3. Click Next.

4. Select I accept the terms in the License Agreement (See Figure 5.4).

5. Click Next.

6. Verify that all features are selected (See Figure 5.5).

7. Select the Installation Folder tab.

8. Verify the installation path.

9. Click Next.

10. Click Install.

11. After the installation is complete, click Finish.
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Figure 5.5: SMS Installer Welcome

5.5 Create Databases

5.5.1 Configure Database Names

Refer to the System Configuration Worksheet for the values of variables in angle brackets.

1. Open SMS PowerShell from the Start Menu.

2. Type Set-SMSDatabaseNames -DatabasePrefix "<WEB APP NAME>”.

Note: This configures the database name for this session. If you want to specify an existing
database name instead of applying a database prefix, use the -InventoryDatabaseName
parameter instead of -DatabasePrefix.

5.5.2 Create Database Scripts Using PowerShell

1. Use the same SMS PowerShell session. Refer to the System Configuration Worksheet for the values of
variables in angle brackets.

2. Type Export-SMSDatabaseScripts -DatabaseServer "<SQL SERVER NAME>"
-winAuthentication.

Note: This configures the database for Trusted Authentication. If you want to specify SQL
Server Authentication, use the -sqlAuthentication switch with the -DatabaseUser
parameter. After typing -DatabaseUser "<SQL AUTH USERNAME>", you will be prompted
for the associated password.

3. Do not close the PowerShell session, because it will be needed to complete the installation.

5.5.3 Move Scripts to Database Server

Copy the folder specified by the Export-SMSDatabaseScripts command to the database server.

20



Chapter 5: Installation SMS with BUILDERTM Version 3.3.8

5.5.4 Execute Database Create Schema Script

1. Open SQL Server Management Studio with a user that has permissions to create a database.

2. Open SMS create script.sql from the folder you just copied in 5.5.3.

3. Execute the script to create the database schema.

5.5.5 Grant Database Roles

Grant <POOL IDENTITY> the db owner role to both databases and close SQL Server Management Studio.

5.5.6 Execute Database Insert Data Script

1. Open a command prompt on the database server.

2. Change the directory to the folder with the database scripts copied in 5.5.3.

3. To load required data for a new SMS database, either double-click on .\SMS bcp data.bat OR type
.\SMS bcp data.bat and press Enter. The loading process may take a few minutes.

4. Close the command prompt and return to the IIS server.

5.6 Create Web Application

5.6.1 Create SMS Application Using PowerShell

Refer to the System Configuration Worksheet for the values of variables in angle brackets.

Using the previously opened PowerShell session, type

Install-SMSApplication -Site "<DEFAULT WEBSITE>" -Name "<WEB APP NAME>"
-DatabaseServer "<SQL SERVER NAME>" -ApplicationPoolUser "<POOL IDENTITY>"
-winAuthentication -clearLogfile -verbose

Note: This configures the database for Trusted Authentication. If you want to
specify SQL Server Authentication, use the -sqlAuthentication switch with the
-DatabaseUser parameter. After typing -DatabaseUser, enter the value for
<SQL AUTH USERNAME>. You will be prompted for the associated password.

5.6.2 Set SMS Administrator Account Password

1. Type Set-SMSAdministratorPassword -Name "<SQL AUTH USERNAME>"

2. As prompted, enter a password for the SMS Administrator account. If you keep the System Configu-
ration Worksheet (Appendix A) in a secure place, this password may be entered in the Worksheet as
<ADMIN PASSWORD>.

5.6.3 Open SMS Application Using Internet Explorer

1. Open Internet Explorer.

2. Open http://localhost/<WEB APP NAME>

21



SMS with BUILDERTM Version 3.3.8 Chapter 5: Installation

5.7 Configure the Service

5.7.1 Modify Service on IIS Server

1. At the upper right, select Tools, (Alternatively, for Windows Server 2008, open the Administrative
Tools ->Services snap-in, and skip the next step.)

2. From the dropdown, select Services.

3. Double-click Sustainment Management System Services.

4. Change Startup Type to Automatic.

5. Select the Log On tab.

6. Change the Log on as to “This account” and fill in the <POOL IDENTITY> configuration settings.

7. Click OK but do not close Services.

8. Open SMS Service Configuration from the Start menu.

9. Click File ->Open and search for the ImpactConfiguration.xml file located in “%ProgramFiles%\ERDC-
CERL\SMS\SMS Service”.

10. Click Settings ->New and fill out the form.

11. After filling out the form, click File ->Save.

12. Start Sustainment Management System Services from Services.

5.7.2 Additional Configuration Options

For further configuration options to customize your installation, and for information about managing this
product, see the corresponding Sustainment Management SystemTM System Administration Guide.

5.8 Configure Custom Reports (Optional)

Below are instructions for installing and configuring the software necessary for publishing custom reports.
For how to publish custom reports, see the Sustainment Management SystemTM System Administration
Guide.

5.8.1 Install SQL Server Reporting Services (SSRS)

1. Install SSRS on the SQL Server or on a different server, to offload report generation.

2. On the System Configuration Worksheet, enter that server’s machine name as the value for <SSRS NAME>.
Alternatively, if the machine has a URI, that could also be used as the value for <SSRS NAME>.

5.8.2 Configure the SMS Inventory database

To configure the SMS inventory database to use SSRS custom reports,

1. Open SQL Server Management Studio.

2. On the inventory database, run the three-command update script below to enable remote processing.
The first command tells the server that you want to use custom reports. The second command specifies
the report server location. The third command gives the location where the reports will be published
to.
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update [dbo].[Configuration]
set [ConfigValue] = ’True’

where Configuration.ConfigName = ’UseRemoteCstmRpts’
GO

update [dbo].[Configuration]
set [ConfigValue] = <SSRS NAME>/ReportServer’

where Configuration.ConfigName = ’CstmRptSvrURI’
GO

update [dbo].[Configuration]
set [ConfigValue] = ’/Custom Reports/<WEB APP NAME>/Reports’

where Configuration.ConfigName = ’CstmRptSvrRoot’
GO
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Appendix A

System Configuration Worksheet

The following table presents installation parameter variables, in alphabetical order. It is recommended to
fill in the values for these variables either in advance of or during installation.

Variable Description Value
<ADMIN NAME> System administrator user

name
For basic installation this will always be
”Administrator”

<ADMIN PASSWORD> System administrator pass-
word

<DEFAULT WEBSITE> Default Web domain for the
SMS application

By default, this is ”Default Web Site”

<LICENSEE> Licensee alias as issued by
the SMS vendor

<POOL IDENTITY> Domain or Local user that
the application will run-as

<SQL AUTH USERNAME> SQL Authentication user
name

<SQL SERVER NAME> Name of the SQL server
<SSRS NAME> Name of the server where

SSRS is installed
<VERSION NUMBER> SMS version number being

installed
<WEB APP NAME> Name of the Web application

that the SMS is installed into
<WEB APP ROOT> The path to the web applica-

tion root directory*

*The path to the web application root directory will be the concatenation of three items, connected by
two single backslashes:

1. Where the inetpub directory is (followed by a backslash)

2. The value of <DEFAULT WEBSITE> (followed by a backslash)

3. The value of <WEB APP NAME>
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